iPad device: iOS 9, 10 and 11.

 

iPad Pro models are supported as well.


If the device you are using is quite old and outdated then the access to the nextINTERACT application version will only allow you to download the highest version of the application compatible for your device. This means you will be unable to download the latest version of nextINTERACT due to your devices hardware and version.